Degraded Performance for Flock

Incident Report for Flock

Resolved

Our team identified and resolved the underlying issue, and all systems are now operating normally. We appreciate your patience and apologize for any inconvenience caused.
Posted Jul 09, 2026 - 15:30 UTC

Investigating

Our team is investigating an issue with degraded group message delivery
Posted Jul 09, 2026 - 12:30 UTC
This incident affected: Group Messaging.